Нова версія phpBB 3.1 “Ascraeus” вимагатиме PHP 5.3.2

Прочитайте перед тим, як розміщувати повідомлення!
Відповісти
Аватар користувача
Support
Адміністратор сайту
Повідомлень: 213
З нами з: 03 грудня 2007, 23:34
Звідки: Lutsk
Контактна інформація:

Нова версія phpBB 3.1 “Ascraeus” вимагатиме PHP 5.3.2

Повідомлення Support » 11 березня 2012, 13:47

Наступному релізу phpBB, PhpBB 3.1 “Ascraeus” буде потрібно PHP версії 5.3.2 або новішу.

PHP 5.3 надає важливу функціональність, таку як використання кількості створених проектів. В PhpBB доцільно використовувати компоненти інших проектів, таким чином, має сенс підвищення мінімальної версії PHP до 5.3, це дозволить PhpBB повторно використовувати деякі компоненти Symfony замість перевизначення еквівалентної функціональності. Це дозволить прискорити завершення PhpBB 3.1 за рахунок скорочення обсягу роботи, яку виконуватиме команда розробників.

Усі основні дистрибутиви вже включають PHP 5.3.2 або вище в поточних стабільних версіях.

PhpBB 3.0 “Olympus” продовжуватиме вимагати PHP 4.3.3 як мінімальну версію.

PhpBB 3.0.10 підтримує PHP 5.3. Версії до PHP 5.2 більше не підтримуються розробниками PHP, усім користувачам, які ще не запустили PHP 5.3, настійно рекомендується перейти на PHP 5.3.

Як PhpBB 3.1 “Ascraeus” знаходиться в стадії активної розробкт, є ще достатньо часу, щоб оновити PHP.

Крім того, слід зазначити, що ця заява не означає, що в PhpBB 3.1 більша частина коду буде переписана для того, щоб скористатися перевагами нових можливостей в PHP 5.3. Насправді фрагменти коду будуть оновлюватися по мірі необхідності.

Відповісти

Хто зараз онлайн

Зараз переглядають цей форум: Немає зареєстрованих користувачів і 1 гість